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1 Introduction 
1.1 SERCOS Slave Conformizer 
 
The Slave Conformizer provides a powerful but easy-to-use development 
environment for testing SERCOS Drives as well as I/O stations according to the 
international standard IEC/EN 61491. The Slave Conformizer has been specifically 
designed to enable manufacturer’s to test the SERCOS interface communication of 
their Slave implementations more extensively and in a fraction of the time than 
would be necessary with tests written using C or C++. 
 

1.2 Slave Conformizer Environment 
 
The Slave Conformizer environment consists of following components: 
 

 SERCOS Master Driver: 
The real-time Master Driver fully supports the new SERCON816 ASIC with 
transmission rates up to 16 Mbits/s and cycle times down to 500 µ s.  The driver 
can be easily configured either via a dialog or using script functions. Toolbars are 
provided for starting and stopping the driver, changing the communication 
phase, selecting the active device address and setting the telegram type.  
Application Telegrams can be easily configured using  a powerful dialog.  

 
 SERCOS Scripting Language  (SSL) 

This is a high-level language with control flow statements, over 100 functions, 
variables and input/output programming features.  
 

 Parameter Browser 
This Browser shows which SERCOS Slave Devices are currently in the ring and 
displays all parameters and their elements as a tree structure. Elements can be 
either read or written and the name of a parameter is automatically displayed on 
moving the mouse’s cursor over a parameter’s number.    
 

 Command Shell 
The Command Shell allows Master Driver functions to be accessed directly. An 
intelligent recall buffer allows previously executed commands to be quickly 
recalled without having to retype them. Recognized functions are automatically 
highlighted. 

 
 Script Editor 

The Script Editor allows complex tests (SCS-files) to be created, managed, 
executed and debugged.  Recognized functions and programming constructs are 
automatically highlighted. The first line of the script can be used to define a 
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name for the script file which is displayed both in the Batch Test Overview and 
by the Script Browser.  
 

 Function Browser 
This Browser displays all script functions as a tree structure. Script functions can 
be found either using the index or the contents tree. Each function lists both it’s 
input and return parameter and can be inserted either in the Command Shell or 
Script Editor by simply double-clicking the function name. 

 

 Script Browser 
This Browser shows all predefined and used-defined directories and script files 
as a tree structure.  It can be used to open script files or to create a batch test by 
selecting which script files should be added to the Batch Test Overview. The 
script tests name is automatically displayed on moving over a script file with the 
mouse cursor.   

 
 Batch Test Overview 

The Batch Test Overview together with the Script Browser allows test scenarios 
to be created, configured and executed.  

 
 Protocol 

The protocol window shows which functions have been called and their return 
values. This formatted and color-highlighted protocol can be saved in Rich Test 
Format and viewed using Microsoft’s Word or printed out directly from the 
Slave Conformizer. Four different information levels are available from low 
(Level 1) to high detail (Level 4). Level 4 includes echoing of a script’s command 
lines and comments. 

 
 Error Code Browser 

This Browser lists all error codes in hexadecimal returned either by the Slave 
Device or from the Master Driver with the corresponding error messages. 
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2 Installing the Slave Conformizer 
2.1 Recommended System Requirements 
 

 Intel Pentium II or Pentium III 
 

 128 MB RAM 
 

 Microsoft’s Windows NT (Service Pack 6) 
 

 Microsoft’s Internet Explorer 5.x 
 

2.2 Installing the Hardware 
 

 Switch off your PC and open the housing in accordance with the 
manufacturer’s instructions. 

 
 Insert the Beckhoff PCI card into a free PCI slot. 

 
 Boot your PC 

 

2.3 Installing the Software 
 

 Before installing the Slave Conformizer software please make sure that RTX 
5.0 RT WinNT and Microsoft’s Internet Explorer 5.x are properly installed. 

 
 Insert the SERCOS Conformizer CD into your CD-ROM drive. 

 
 If the setup program does not start automatically, please click on the setup.exe 
located on the SERCOS Conformizer CD.    
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3 Using the Slave Conformizer 
 

3.1 Connecting the Fiber Optic 
 
For the Slave Conformizer the “Channel A” receiver and transmitter must be used. 
 

3.2 Entering the Slave’s Configuration 
 
After starting the Slave Conformizer, a configuration dialog for the Slave Device to 
be tested appears. The baud rate and cycle time supported by the Slave Device must 
be correctly configured before starting the Master Driver.  The Master Driver uses 
the maximum baud rate supported by the Slave Device and minimum cycle time 
supported down to 500 µ s. For cycle times less than 1 ms, a cycle time of 1 ms is used 
for CP0-2 according to the IEC/EC 61491. Otherwise the cycle time for CP0-2 is the 
same as that for CP3-4.  
 
The device address of the Slave to be tested should also be correctly set, but can also 
be changed after the Master Driver has been started by using the Slave Device 
Toolbar. It should be noted that unlike normal SERCOS Masters, the SERCOS 
Conformizer Master Driver always communicates with only one Slave Device at a 
time. If several Slave Devices are in the SERCOS ring, it is still possible to 
communicate with each Slave Device by changing the active Slave Device using the 
Dialog Toolbar provided. It is however not possible to change the communication 
phase of all Slave Devices simultaneously. This was the only way to prevent other 
Slave Devices in the SERCOS ring from interfering with the Slave Device being 
tested.  However when performing a Conformance Test it is still recommended that a 
Slave Device is tested with no offer Devices in the ring, since incorrectly 
implemented Slave Device’s in the same ring can still cause incorrect test results.   
 
After entering the Slave’s configuration you have the option to start the Master 
Driver. The Master Driver can also be started or stopped using the corresponding 
buttons on the Main Toolbar. The communication phase of the active Slave Device 
can be changed using the Communication Phase Toolbar. After starting the Slave 
Conformizer, the Parameter Browser, Command Shell and Protocol Window are 
displayed.   
 

3.3 Using the Parameter Browser 
On expanding the Parameter Browser, the Master Driver searches the SERCOS ring 
for Slave Devices and displays them. After expanding a found Slave Device, a list of 
S- und P-Parameters can be viewed. Further expanding of a particular Parameter 
displays it individual elements which if allowed can also be changed. If several Slave 
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Devices are found it is also possible to read and write parameters for each Slave 
Device. The parameter browser automatically changes the active Slave Device and 
communication phase for you. To change the value of a parameter’s element, either 
click to edit or use the context menu. On pressing return the value is changed if the 
write was successful. To check that the value was written correctly simply re-expand 
the element that was changed. 
 

3.4 Using the Command Shell 
In the Command Shell script functions listed in the Function Browser can be 
executed. As already mentioned the Slave Conformizer only communicates with the 
active Slave Device selected by the Slave Device Toolbar. For example if Slave Device 
1 is active before entering the following, pressing return causes the Slave 
Conformizer to try and change this device’s Communication Phase to CP 2: 
 
change_phase(2); 
 
The communication phase of the Slave Device should change to 2. This should also 
be displayed by the Communication Phase Toolbar, but can also be queried using: 
 
read_phase(); 
 
Any other devices in the SERCOS ring should show CP0.  Using the Communication 
Phase Toolbar has the same affect as calling change_phase(). 
 
Furthermore entering the following and pressing return, commands the Slave 
Conformizer to the read data value of IDN S-0-0002 from the Slave Device which is 
currently active: 
 
read_data(2); 
 
In the Command Shell and Script Editor, as soon as a entered function name is 
recognized it is automatically color-highlighted. Try out further functions by simply 
double-click functions listed in the Function Browser and editing if necessary the 
input arguments. You can use the up and down cursor keys to recall past commands. 
For an intelligent search of past commands, enter one or some of the first letters of 
the command desired and press the up cursor key until the command desired is 
shown. 
 
It is also possible to use variables and if expressions in the command shell. For more 
information please see Section 4 of this document. 
 

3.5 The Protocol Window 
When a script function is called, either from the Command Shell or from a script file, 
a message is displayed in the Protocol Window showing: 
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 the time when the function called (timestamp),  
 the script file line number (for script files only),  
 the communication phase as the function was called,  
 the active Slave Device as the function was called,  
 the parameter or info read or written,  
 the element type read or written,  
 the value of element read or written or an error code and message, if the value 

could not be changed or read. 
 
The Protocol Window displays formatted and color-highlighted messages for each 
script function. This Protocol can either be printed directly from the SERCOS 
Conformizer (File->Print Protocol) or saved in Rich Text Format (RTF) (File->Save 
Protocol). The RTF-Format preserves the formatting and color-highlighting and 
allows the Protocol to be viewed and printed with an external viewer such as 
Microsoft’s Word or with WordPad. For the purposes for File Comparing protocols it 
is possible to deactivate the timestamp (see Edit->Preferences->Timestamp).  
 
Using the protocol’s context menu or clicking with the right mouse button on the 
protocol window the information level for the protocol can be selected.  
Info Level 1: lowest level, no diagnosis info included (S-0-0095) 
Info Level 2: default level, includes diagnosis info (S-0-0095) when changing phase 
Info Level 3: debugging level, includes Level 2 info and echoes Script file commands 
Info Level 4: highest level, includes Level 3 info and also echoes Script file comments 
 
Using the right mouse button it is also possible to copy the content of the protocol 
window or to clear the protocol window. 

3.6 Using the Script Editor 
Files that contain code in the SSL language for the Slave Conformizer are called SCS 
(Slave Conformizer Script) script files. You can create same script files using the 
Script Editor or an external text editor of your choice. When you run or step a SCS 
script file from the Script Editor, the Slave Conformizer automatically executes the 
commands found in this script file. 

3.6.1 Creating a New Script File 
To create a new test select File->New Script or use the Main Toolbar button. If you 
enter a comment in the first line, this comment is displayed in the script browser 
(when you move the cursor over a script file) and in the batch test overview as the 
test name. In the script file you can use any of the script functions listed in the 
Function Browser and the programming constructions described in Section Fehler! 
Verweisquelle konnte nicht gefunden werden.. As in the Command Shell, Script 
Commands can be copied to the Script Editor Window by double-clicking a function 
listed in the Function Browser. Functions are also automatically color-highlighted as 
soon as they are recognized. Keywords such as if and end are also color-highlighted. 
To deactivate or reactivate the syntax-highlighting select Edit->Preferences->Syntax-
Highlighting.  



SERCOS  Slave Conformizer –  User’s Guide  

 9 

3.6.2 Open a Existing Script File 
To open an existing script file you can either use:  

 File->Open Script  
 double-click a file using the Script Browser, 
 or use the context menu of the Script Browser. 

3.6.3 Executing a Script File 
To execute a script select the  button from the Control Toolbar. The Protocol 
Window shows you which script was started and when it was been finished. To 
abort the execution of the script function use the  button.  

 

3.6.4 Debugging a Script File 
To debug a script file, first set the info level of the Protocol Window to Level 3 or 4 
use the context menu option. Then step into the script file using the  Button of the 
control toolbar. By pressing this button you can step through the script file.  
  

3.7 Using the Batch Test Mode 
By selecting the Batch Test view, it is possible to create a batch test by checking the 
directories or files displayed in the script browser. By moving the cursor over a script 
file, the test’s name is displayed automatically. The Batch Test Overview window 
shows which files have been selected and allows you to change the order in which 
they are executed using the context menu. To execute the batch test select the  
button from the control toolbar.  The Batch Test Overview shows which test is 
currently being executed and the result and number of fails (if applicable) for 
completed tests.  A batch test can be aborted using the  button.  
 

3.8 Using the Application Telegram Configuration 
By selecting the Configuration->Application Telegram it is easily possible to 
configure the application telegram . The lists S-0-0187, S-0-0188, S-0-0016 and S-0-
0024 are read and their contents are displayed. Also the maximum allowed lengths 
(S-0-0185 and S-0-0186) are displayed. Elements can be added to the configuration 
lists by using the “Add” button and removed by using the “Remove” button. The 
configuration is written to the drive by selecting the “OK” button. 
 

3.9 Using the Ramp Up Configuration 
By selecting the Configuration->Application Telegram it is possible to command a 
ramp for a cyclically configured ident number. The drive is switched to CP 4 and the 
user is asked to switch the main power on. Then a dialog to configure the movement 
of the drive opens.  
The elements of the ramp up dialog are: 
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 Ident Number 
Cyclically configured ident number that should be used for the ramp 
movement.  

  Name 
The name of this ident number.  

 
 Ident Number for Start Data 

This ident number is used to define the first cyclically written value. If the 
cyclically written ident number is for example the position command value 
the actual position value should be used as start data. It is also possible to 
select the start data as editable. 

 Name 
The name of this ident number. 

 Unit 
The Unit of this ident number.  

 Start Data 
The value of the start data.  

 
 Increase cycles 

The number of increase cycles. In every increase cycle the Add Data value is 
added to the cyclic data. 

 Constant cycles 
The number of constant cycles. In the constant cycles the cyclic data stays the 
same. 

 Decrease cycles 
The number of decrease cycles. In every decrease cycle the Add Data value is 
subtracted from the cyclic data. 

 
 Unit 

The unit of the Add Data. 
 
 

 Add Data 
The value that is added to or subtracted from the cyclic data. 

 
 Repeat Movement 

By selecting this the movement is repeated until the user selects the Stop 
Movement dialog. 
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4 SERCOS Scripting Language (SSL) 
4.1 Expressions 
The building blocks of expressions for SSL are 
•Variables 
•Numbers 
•Operators 
•Functions 
 

4.2 Functions 
SSL provides a over 100 predefined functions. For a complete list of available 
functions use the Function Browser. A detailed description of each function can be 
found in the Slave Conformizer’s Reference Guide.  

4.3 Special Functions 
get_last_error() 
If you look at the functions listed in the function browser you will see that some 
functions return error codes while other functions return a double value such as a 
element’s data value. If the element’s data value for example could not be read then 
the function returns DBL_MAX (1.79e+308). In order to find out the error code of 
such functions you can use the function get_last_error() 
 
fail_test() 
When this function is called the fail counter for this script file is incremented by one. 
The total number of fails is displayed during a batch test. By combining the 
get_last_error() function with an if construct, the fail_test() function can be used to 
determine whether or not the previously called function returned 0 for no errors or a 
known error code. Since it is generally not possible for the Slave Conformizer to 
know whether a function call should succeed or not, function calls returning an error 
are displayed in green. Only when the fail_test() is called or a serious communication 
error occurs is a message displayed in red.  
 
abort_test() 
The abort_test() function should be used instead of fail_test() if a error in the test is so 
severe that it prevents the test from being continued. After abort_test() has been 
called the test is then immediately aborted. In the Protocol Window and Batch Test 
Overview the test is displayed as having been aborted. This test is then considered to 
have failed. 
 
skip_test() 
In some causes, a test cannot be executed because the functionality being tested does 
not have to be supported. In such situations the skip_test() function can be used to 
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stop a test prematurely. In the Protocol Window and Batch Test Overview such tests 
are displayed as having been skipped. These tests are not considered to have failed.  
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5 Learning More 
 
For more SLL examples, look at the Conformance Test script files provided with the 
Slave Conformizer. For the very latest information about the Slave Conformizer 
including product updates, the newest Conformance Test script files, product 
documentation etc. point your Web browser to: 
 
http://www.sercos.de 
 
The documents can be found in the Download Area, Documents for Certification. 
 


